代理人から非公開のアイテムが参照できなくなった場合や代理人設定時に「[代理人] タブの設定は正しく保存されませんでした」エラーが発生する場合の対処方法について

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現象

代理人アクセスの設定時に 「代理人に非公開に設定したアイテムへのアクセスを許可する」 をオンにしておくことで、代理人は非公開のアイテムであっても参照を行うことが可能です。この設定を行っているにもかかわらず非公開のアイテムの参照ができない場合や代理人設定時以下のようなエラーが発生する場合があります。
※ エラーメッセージは異なる場合もあります。

「[代理人] タブの設定は正しく保存されませんでした。空き時間と予定の入っている時間の情報をアクティブできません」

[代理人] タブは使用できません。 Outlook フォルダーにアクセスできません。

原因

非公開アイテムの設定が格納されている Freebusy フォルダーやルールに不整合が生じている場合に発生します。

対処方法

(1) 無効にされたユーザーの代理人権限の削除

このエラー メッセージが表示される場合の多くの原因が、複数の代理人がいるシナリオで、代理人設定を付与したまま一部のユーザーが削除されてしまったときであることを確認しています。過去に代理人設定をし、権限を削除する前にユーザーやメールボックスの削除を行った場合は、対象ユーザーの代理人権限を削除してください。

予定表フォルダーに対して付与した権限を以下のコマンドで削除します。

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# フォルダー名が日本語の場合は、`<被代理人>:\予定表` と指定します。  
Remove-MailboxFolderPermission -Identity <被代理人>:\calendar -User <削除済みの代理人>

この手順は特定のユーザーの権限のみを削除するものであるため、削除されたユーザー以外の代理人動作などには影響はありません。このコマンドでエラーが回避できない場合は、Exchange Online をご利用であれば (2) の手順をお試しください。Exchange オンプレミスをご利用であれば (3) の手順をお試しください。

※ 対処する削除済みユーザー (削除済みの代理人) と同じ表示名のユーザーが作成されている場合、上記のコマンドではエラーとなって削除できない場合がございます。
その際は -Force をつけて再度コマンドを実行いただきますようお願いいたします。

(2) ResetDelegateUserCollection スイッチで代理人設定と隠しルールを削除

管理者から以下のコマンドレット スイッチを実行し、隠しルールと代理人設定をリセットします。

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Remove-MailboxFolderPermission -Identity <被代理人>:\calendar -ResetDelegateUserCollection

このコマンドは、予定表の参照や書き込みの権限は削除しませんが、対象の被代理人 (役職者) が設定している全ての代理人権限が削除されます。代理人特有の以下のような動作は利用できなくなります。

  • 会議出席依頼を代理人に転送する
  • 非公開のアイテムを参照する

加えて、以下のコマンドで代理送信権限を削除します。

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Set-Mailbox <ユーザー> -GrantSendOnBehalfTo $null

これらのコマンド実行後は代理人の設定がクリアされます。被代理人による代理人の再設定が必要となるため、実行される際にはタイミングに十分ご注意ください。こちらで回避できない場合は、(3) の手順をお試しください。

(3) MFCMAPI による Freebusy フォルダーの初期化とルールの削除

Freebusy フォルダーの初期化と代理人のルールの削除を行ってから、代理人の再設定を行うことで事象を解消することができます。

事前準備

代理人設定については、[ファイル]タブ -[アカウント設定]-[代理人アクセス] をクリックし、スクリーンショットを採取しバックアップとしてください。

手順

  1. 代理人を設定する側の端末にて Outlook を終了の上、以下の URL から MFCMAPI.exe をダウンロードします。

    https://github.com/stephenegriffin/mfcmapi/releases

    ※ インストールされている Office クライアントの bit にあわせてダウンロードをお願いします。

    例:
    32 bit : MFCMAPI.exe.23.0.23089.01.zip
    64 bit : MFCMAPI.x64.exe.23.0.23089.01.zip

    ※ 最新バージョンで何らかの問題が発生する場合は過去にリリースされているバージョンをお試しください。

  2. zip ファイルを実行して、C:\MFCMAPI などとフォルダーを指定して解凍します。

  3. 解凍されたファイルの MFCMAPI.exe を起動します。

  4. [About MFCMAPI] というダイアログが表示されたら [OK] をクリックします。

  5. [Tools] - [Options] をクリックします。

  6. “Use the MDB_ONLINE flag when calling OpenMsgStore” をチェックをオンにし、[OK] をクリックします。

  7. [Session] - [Logon] をクリックします。

  8. プロファイル選択が表示されたら、対象のプロファイルを選択して、[OK] をクリックします。

  9. [<本人のメールアドレス>] をダブル クリックします。

  10. [Root Container] - [Freebusy Data] をダブル クリックします。

  11. 新しく開いた [Freebusy Data] ウィンドウにて、[Subject] 列が [LocalFreebusy] のアイテムを右クリックし、[Delete message] をクリックします。

  12. “Deletion style” を [Permanent delete passing DELETE_HARD_DELETE (unrecoverable)] に変更の上、[OK] をクリックし、ウィンドウは [X] で閉じます。

  13. 次に [Root Container] をクリックします。

  14. 右ペインに表示されている一覧から、[Name] 列が “PR_FREEBUSY_ENTRYIDS” で始まるエントリを右クリックして [Delete Property] を選択し、確認ダイアログが表示されたら [OK] をクリックします。

  15. さらに [Root Container] - [インフォメーション ストアの先頭 (または、Top of information Store 表記)] - [受信トレイ] をクリックします。

  16. 右ペインに表示されている一覧から、[Name] 列が “PR_FREEBUSY_ENTRYIDS” で始まるエントリを右クリックして [Delete Property] を選択し、確認ダイアログが表示されたら [OK] をクリックします。

  17. 引き続き、代理人についてのルールを削除します。

  18. [Root Container] - [インフォメーション ストアの先頭 (または、Top of information Store 表記)] - [受信トレイ] を右クリックして [Other tables] - [Rules table] をクリックします。

  19. 上半分の 1 行目を選択し、下半分の [PR_RULE_PROVIDER] で始まるエントリーの [Value] 列が [Schedule+ EMS Interface] になっているかを確認します。

  20. [Schedule+ EMS Interface] になっている場合は、上半分側で選択している行を右クリックして [Delete] をクリックして削除します。

  21. [Schedule+ EMS Interface] になっている他の行に対しても同様に作業を行います。

  22. MFCMAPI を終了します。

  23. Outlook を起動します。

  24. [ファイル]タブ - [アカウント設定] - [代理人アクセス] をクリックします。

  25. 現在設定されている代理人をすべて削除します。

  26. Outlook を再起動します。

  27. [ファイル]タブ - [アカウント設定] - [代理人アクセス] をクリックします。

  28. 代理人の再設定を行います。
    代理人の設定をエラーなく完了できるか、代理人側より非公開のアイテムの参照が可能かご確認ください。
    代理人側からの参照ができない場合には、代理人の Outlook プロファイルの再作成もお試しください。

(4) 仕分けルールのリセット

(3) の作業を行っても解消しない場合や MFCMAPI を利用して作業することができない場合は、仕分けルールをリセットすることで解消するかを確認します。
注意: 仕分けルールがリセットされるため、仕分けルールを再設定する必要があります。

  1. Outlook の仕分けルールをバックアップします。
    (Outlook の [ファイル] タブ-[仕分けルールと通知の管理]-[オプション]-[仕分けルールをエクスポート]-任意の場所に任意のファイル名で .rwz ファイルを保存)
  2. Outlook を終了します。
  3. Windows キー+R キーを押し、outlook /cleanrules と入力して実行します。仕分けルールがリセットされてから、Outlook が起動されます。
  4. 現象が解消しているかを確認します。
  5. 手順 1 でバックアップしていたファイルをインポートします。
    (Outlook の [ファイル] タブ-[仕分けルールと通知の管理]-[オプション]-[仕分けルールをインポート] から .rwz ファイルを指定)
  6. 現象が解消しているかを確認します。
  7. 手順 4 では発生せず手順 6 で発生する場合はインポートしたルール情報に依存しているため、以下のような方法での対処を行います。
    • すべての仕分けルールを手動で削除しても現象が発生する場合は、再度手順 3, 4, 5 を行った後、手動ですべての仕分けルールを作成し直す。
    • すべての仕分けルールを手動で削除すると解消する場合は、再度 .rwz ファイルをインポートしてから問題の仕分けルールの切り分けを行い、問題の仕分けルールのみを作成し直す。

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